Excel formules over meerdere werkbladen

In Excel is het eenvoudig om te verwijzen naar cellen op een ander werkblad. Als het document uit meerdere werkbladen bestaat kan eenvoudig in bijvoorbeeld cel A1 van werkblad4 een optelling worden gemaakt van de waarden uit de A1-cellen over de voorafgaande werkbladen met de formule:

=Werkbladnaam1A1 + Werkbladnaam2!A1 + Werkbladnaam3!A1

Maar als het bestand uit heel veel werkbladen bestaat wordt het al gauw onoverzichtelijk, met als gevaar dat een werkblad vergeten wordt. Bijvoorbeeld onderstaand bestand bestaat uit 13 werkbladen:

meerdere_tabbladen_tegelijk_bewerken1_634x96

Het is de bedoeling dat in het totaalblad optellingen worden gemaakt over de voorafgaande werkbladen. Stel dat in cel C3 een optelling moet worden gemaakt over de waarden van C3 van de 12 voorafgaande werkbladen, dan kan dat eenvoudig met de volgende formule worden gedaan:

=SOM('jan:dec'!C3)

(NB: Vervang bij Engelstalige Excel-versies SOM door SUM)

Alle cellen C3 van de werkbladen vanaf ‘jan’ tot en met ‘dec’ worden hierbij opgeteld. Dit werkt veel gemakkelijker en sneller en met minder kans op fouten dan door alle werkbladen apart in de formule te benoemen.

 

Interesse in andere tips & trucs? Ga dan naar ons tips&trucs-overzicht of neem een kijkje op onze pagina met tutorials.

Reacties op onze tutorials en tips&trucs zijn van harte welkom. Dat kan door hieronder een reactie toe te voegen of door rechtstreeks contact met ons op te nemen.

71 reacties op Excel formules over meerdere werkbladen

  • reuze bedankt ging in 1 keer goed koppelen van men werkbladen TOPPIE

    • Bedankt voor je reactie.Mooi dat het gelukt is.

  • en als het nu eens ipv maanden, bijv weken zijn? Ik bedoel dat je een aantal bestaande werkbladen hebt bijv. week 21, wk 22, wk23 enz. dan kun je ook deze formule toepassen.
    Maar wat te doen met de weken die nog komen? wk 24, wk 25, wk 26 enz?

    • Om de formule goed te laten werken moet je ervoor zorgen dat het eerste tabblad en het laatste tabblad in de formule zijn opgenomen. Dus als er extra weken bijkomen, moeten deze tabbladen aansluitend aan de andere tabbladen geplaatst worden. De formule moet daarna aangepast worden. Je kunt bijv. ook een extra leeg tabblad aan het eind plaatsen (bijv wk 00) en de formule laten lopen t/m tabblad wk 00. Nieuwe weken hoeven dan alleen voor wk 00 ingevoegd te worden en lopen dan automatisch mee in de optelling. De formule hoeft in dat geval niet aangepast te worden.

  • Is de functie GEMIDDELDE.ALS ook over meerdere werkbladen te gebruiken? Ik wil namelijk de gemiddelden van waardes in een bepaalde cel, bijv. B17, over meerdere werkbladen berekenen wanneer in een bepaalde cel, bijv B8, voldaan wordt aan een voorwaarde. Dus wanneer op een werkblad in cel B8 “ja” is ingevuld, dan moet de waarde in cel B17 meegenomen worden in de gemiddelde berekening. Gebruik ik dan trouwens de juiste formule? Ik heb nu de volgende formule: =GEMIDDDELDE.ALS(eerste:laatste!$B$8;”ja”;eerste:laatste!B17) waarbij ik met eerste en laatste het eerste en laatste werkblad aangeef.

    • Hallo Rody,
      De functie GEMIDDELDE.ALS kun je niet gebruiken met deze 3D-referenties. Je kunt dit alleen maar gebruiken bij relatief eenvoudige functies zoals SOM, GEMIDDELDE, MIN, MAX en dergelijke. Een workaround hiervoor is om een hulpcel op elk werkblad te plaatsen. Zet bijvoorbeeld in cel C8 van elk werkblad deze functie: =ALS(B8=”ja”;B17;””). Het GEMIDDELDE.ALS over deze werkbladen kun je dan berekenen met =SOM(eerste:laatste!C8)/AANTAL(eerste:laatste!C8).

  • Manfred, bedankt voor de reactie.

  • En hoe kan ik een gemiddelde berekenen als in kolom A van meerdere werkbladen jaartallen vermeld staan en in kolom Q en R de percentages. Ik wil graag bewerkstelligen dat, als kolom A = 2014, het gemiddelde wordt berekend van de percentages die vermeld staan in kolom Q en R. Overigens staat in die kolommen niet op ieder werkblad een waarde….

    • Dat gemiddelde kun je berekenen door op elk werkblad 2 hulpcellen op te nemen. Zet bijvoorbeeld op elk werkblad in cel S1 de formule: =AANTALLEN.ALS(A2:A100;2014;Q2:Q100;””&””)+AANTALLEN.ALS(A2:A100;2014;R2:R100;””&””) en zet in cel T1 de formule: =SOM.ALS(A2:A100;2014;Q2:Q100)+SOM.ALS(A2:A100;2014;R2:R100). Het gemiddelde van deze percentages over al deze werkbladen kun je dan berekenen met =SOM(eerste:laatste!S1)/AANTAL(eerste:laatste!T1).

      • Manfred, bedankt voor je antwoord. Daarmee ben ik al een eind op weg, maar in de cellen A2:A100 zit een formule en daardoor wordt de waarde daarvan niet gezien als of als “”. Hoe kan ik dat nog aanpassen?

        • Marlies, ik neem aan dat je bedoelt dat in Q2:R100 formules staan i.p.v. in A2:A100. Vervang dan de functie AANTALLEN.ALS door =SOMPRODUCT((A2:A100=2014)*(Q2:Q100″”))

          • Dank je wel, Manfred, het werkt!!

  • Bij mij lopen de tabbladen op elke maand en dan voeg ik via VBA ( die berekend het aantal tabbladen/maanden) deze formule toe aan een cel, dit werkt allemaal prima alleen als uitkomst staat er altijd #NAAM in de cel als ik een nieuw tabblad aanmaakt (via macro) en moet ik eerst de cel selecteren en in de formule balk een return geven om de functie daadwerkelijk door te voeren.

    Heb je misschien enig idee waarom dit zo is en hoe ik dit kan oplossen? Heb van alles geprobeerd in VBA, update, calculate etc…..

    mvg,
    Robert

    • Dag Robert,
      Ik vermoed dat je de Nederlandstalige formule met VBA hebt ingesteld met de eigenschap Formula. Als je echter Formula gebruikt, dan moet je de Engelstalige variant van de formule gebruiken en moet je de eventueel aanwezige puntkomma’s vervangen door komma’s. Dit werkt voor alle taalversies. Als je toch de Nederlandstalige formule wilt gebruiken in VBA, dan kun je gebruik maken van FormulaLocal. Maar houd er dan rekening mee dat dit alleen voor Nederlandse taalversie werkt.
      Groeten, Manfred

      • Hoi Manfred,

        Dit was mijn formule:

        ActiveCell.FormulaR1C1 = "=SOM(" & Worksheets(1).Name & ":" & Worksheets(Worksheets.Count - 1).Name & "!R[-2]C[0])"

        Door SOM te vervangen door SUM werkt het perfect, je had dus gelijk!
        Zo simpel dus…. je moet het maar net weten, heb zoveel uitgeprobeerd eerder….

        Bedankt voor je hulp!

  • Ik zit denk ik met een vergelijkbare uitdaging.
    In verschillende bladen moet indien uitgevoerd een X worden ingevoerd. Op het laatste blad heb ik:
    =ALS(‘Leerlijnen kunst’!B4=”X”;”X”;”O”) Nu kijkt hij alleen op tabblad leerlijnen kunst. Dit moet echter gedaan worden over nog 7 tabbalden. Hoe kan ik in het totaalblad een X in de cel krijgen als de X in willekeurig 1 van de tabbladen in B4 wordt ingevoerd ..

    Alvast bedankt voor het meedenken.

    • Hoi Patrick,
      Ik denk dat je ook in dit geval niet ontkomt aan een hulpcel op elk tabblad. Zet bijvoorbeeld in cel B5 op elk tabblad de formule =ALS(B4="X";1;0) en zet vervolgens op het laatste tabblad (totaalblad) de formule: =ALS(SOM(Blad1:Blad3!B5)>0;"X";"O")

  • =SOM(L10:L43) wordt op elk tabblad uitgerekend, echter moet ik dit nu opgeteld hebben uit 52 tabbladen…..

    Wat voor formule moet ik nu hanteren?

    • Hallo Peter,
      Dat kan bijvoorbeeld met de volgende formule: =SOM(Blad1:Blad52!L10:L43)
      Groet, Manfred

  • Hallo, ik heb een vraag..

    Ik wil een overichtelijke tabel gaan maken waar ik in terug kan zien hoeveel pakketten er verstuurd zijn en wat de prijzen zijn per land. Ik heb 1 bestand geimporteerd waar al deze gegevens in staan vermeld maar hier staan alle 18 landen in.
    Hoe maak ik een formule dat er gefilterd wordt per land naar zijn eigen tabblad? Hopelijk heb ik het zo duidelijk uitgelegd.

    Alvast bedankt.

    Mvg
    Melissa v

    • Hallo Melissa,
      Op zich zou dat normaal gesproken best met formules kunnen, maar op basis van jouw beschrijving zou ik kiezen voor een draaitabel. De gegevens worden dan overzichtelijk gepresenteerd en kunnen dan bijvoorbeeld heel eenvoudig gefilterd worden op land.
      Groeten, Manfred

  • Hallo,
    Ik heb een Excel met enquête antwoorden. Door de aard van de vervolgvragen kunnen de antwoorden van verschillende partners niet onder of achter elkaar. Deze heb ik dus over verschillende tabbladen gezet.
    De vragen zijn allemaal met ja of nee beantwoord. Nu zou ik graag uitrekenen hoeveel ja antwoorden er per vraag zijn gegeven.
    Ik heb het geprobeerd met =countif(‘partner1:partner20’;!D3; “ja”) dat lijkt helaas niet te werken. Ik heb ook geprobeerd op iedere pagina een cel te maken met =ALS(D3=”ja”;1;0) zodat ik een som kon maken op het laatste tabblad, ook deze lukt niet.
    Kunt u mij vertellen waar de fout in mijn formules zit.

    • Hallo Lars,
      COUNTIF (AANTAL.ALS) kun je niet gebruiken in formules over meerdere werkbladen. Je zult dus met een hulpcel moeten werken. Hoe ziet jouw formule voor het bepalen van de som eruit?

      • Ik heb geprobeerd een hulpcel te maken met =ALS(D3=”ja”;1;0) zodat als er een ja staat het 1 wordt en bij nee een 0 Deze werkt helaas ook niet. Ik denk dan kan ik een som over alle paginas doen en weet ik hoeveel keer ja (dus 1) ik heb. Zit er over te denken gewoon alle antwoorden met find en replace in getallen te veranderen.

        • Toch zou de constructie met de hulpcel normaal gesproken goed moeten werken. Stel deze hulpcel is op elk tabblad cel C1, dan wordt de formule voor de som:
          =SOM(eerste:laatste!C1)

  • Hi,

    Bovenstaand kom ik =som(‘blad1:blad10’!I3) tegen.
    Bestaat er ook een mogelijkheid om vertikaal te zoeken over meerdere TAB-bladen.
    Op cel A3 t/m A999 heb ik unieke codes staan, elke TAB weer. die zou ik graag willen gebruiken voor vertikaal zoeken maar dan een optelling van alle volgende TAB-bladen

    • Als het om een beperkt aantal tabbladen gaat, dan is er wellicht best wat te verzinnen met (complexe) formules, maar ik denk dat ik in dit geval voor een UDF zou kiezen (UDF is een User Defined Function m.b.v. VBA). Misschien kan ook een optie zijn om alle codes op één tabblad onder elkaar te zetten. Je kunt dan met weer gewoon vertikaal zoeken werken. Maar dat is helemaal afhankelijk van de opbouw van het bestand.

  • Wat is de formule om niet getallen maar namen op te tellen?
    Ik heb een kalender sheet gemaakt, waar medewerkers hun namen kunnen invullen per vakje wat uiteindelijk dan opgeteld moet worden als aantal gewerkte dagen. Maar ik kom er dus niet uit omdat het namen zijn en geen getallen.

    • Mogelijk kun je wat doen met de functie AANTALARG, maar misschien moet je ook wel wat doen met hulpcellen. Dat is geheel afhankelijk van de opbouw van je sheet. Een precieze formule kan ik je daarom op basis van de verstrekte info niet te geven.

  • nog een vraagje,

    hoe kan ik een kalender inbouwen?
    Ik heb dus een sheet met maandtabs gemaakt en daarin dagen opgenomen maar nu kloppen de datums niet.
    🙂

    • Heeft op zich niet rechtstreeks met het onderwerp van formules over meerdere werkbladen te maken. Zonder het bestand valt hier denk ik weinig over te zeggen. Ik kan vanaf hier niet zien waarom de data niet kloppen.

  • We zijn een bestellijst/voorraadlijst aan het maken. Het volgende:
    Op tabblad 1 willen we een overzichtslijst hebben van alles wat op de andere tabbladen aangevinkt wordt.

    Op deze overige tabbladen hebben we productenlijsten, waarin ik in kolom C,H,M mijn bestellingen verwerk. Ik zou dus graag willen dat, zodra ik bijvoorbeeld in cel C13, op tabblad 2, een 1 zet, dat dan A,B en C13 ook op tabblad 1 komen te staan (het liefst bovenaan), zodat ik gelijk een overzicht heb van wat ik allemaal moet bestellen. Mocht hier dan nog een zelfde product bijkomen (die iemand anders bestelt) dan voer ik dit in op een volgend tabblad stel dit is ook weer een C13, dan wil ik dat deze C13 van vb tabblad 3 bij de C13 van tabblad 1 opgeteld wordt. Tevens zou het dan mooi zijn dat, als de eerste klant ook nog een product bestelt bijv. C15, dat de gegevens van A,BenC15 het tweede punt wordt op tabblad 1 (van de lijst van mijn bestellingen)…enz enz…

    Kan iemand mij helpen? Heel erg bedankt! 😀

    • Het eenvoudigste is om op het eerste tabblad per relevante cel een sommatie te maken over alle tabbladen. Dus voor C13 wordt dat dan: =SOM(Blad2:Blad9!C13)
      De cellen in A en B van het voorblad kunnen dan met een ALS-formule zichtbaar worden gemaakt op het moment dat de waarde in C groter dan nul is. Door een filter op kolom C van het voorblad te plaatsen kun je dan alle regels met nul-waarden verbergen. Als automatisch de ingevulde waarden bovenaan moeten komen te staan dan zal dit zo op het eerste gezicht met een hulpkolom of met VBA moeten.

  • Beste Manfred,

    Ik heb voor mijn medewerkers een document gemaakt, dat ze voor elke dag gegevens kunnen invullen. Het bestand uit 52 tabbladen, die de weken moeten voorstellen. Is er ook een mogelijkheid om de weeknummers aan te geven per tabblad op het veld bijv. A3 en de dagdatum op bijv. op B6 meer automatisch in te vullen. Ipv voor elk tabblad deze velden handmatig het weeknummer en datum in te voeren.

    • Beste Mark,

      Ja, daar is normaal gesproken wel iets voor te verzinnen. Als het tabblad als naam het weeknummer heeft, dan zou je met een formule op elk tabblad de tabbladnaam kunnen weergeven. Ik weet niet precies wat je bedoelt met dagdatum, maar op basis van het weeknummer en jaar zou dan ook een datum kunnen worden bepaald. Ook zouden deze gegevens met een macro automatisch op elk tabblad kunnen worden neergezet.

      • Beste Manfred,
        Het zou heel fijn zijn als je me kunt uitleggen hoe ik de tabbladnaam in een veld kan krijgen.

  • Dag Manfred,

    Ik heb een soort werkrooster gemaakt waarbij er onderscheid is in dag (D), avond (A) en nacht (N).
    Nu heb ik dit voor meerdere locaties gemaakt voor meer medewerkers, maar nu wil ik graag een lijst hiervan automatisch maken dat hij uit alle tabbladen per persoon ook de dagen overneemt. Dan zie ik ook een persoonlijk rooster en niet alleen maar per locatie. (dit omdat sommige medewerkers op meerdere locaties werken).
    Wat is een handige manier om deze letters over te laten nemen naar een ander tabblad, een simpele optelling vanuit tabbladen werkt niet omdat het om letters gaat.
    Graag je advies hier over!

    • Ik denk het gevonden te hebben met de formule van tekst samenvoegen, dit biedt me nog wel opties in ieder geval!

  • Manfred,
    ik heb volgende code :

    Sub FactuurMaken()
    
    Sheets.Add Type:="C:UsersKurtDocumentsBASF2017AlgemeenSjablonenFactuur.xlsx" 'Ophalen Pakket Van de Velde
    
    ThisWorkbook.Sheets("Pakket Van de Velde").Activate
    
    With ThisWorkbook.Sheets("Pakket Van de Velde")
        Range("E6").Activate
            With ActiveCell
                .FormulaR1C1 = "=SUM('14.06.2017:30.05.2017'!R[0]C[3])"
            End With
        Selection.AutoFill Destination:=Range("E6:E25"), Type:=xlFillDefault
        Range("E26").FormulaR1C1 = "=sum('14.06.2017:30.05.2017'!R[1]C[3])"
        Range("E28").Activate
            With ActiveCell
                .FormulaR1C1 = "=SUM('14.06.2017:30.05.2017'!R[10]C[3])"
            End With
        Selection.AutoFill Destination:=Range("E28:E38"), Type:=xlFillDefault
        Range("E39").FormulaR1C1 = "=sum('14.06.2017:30.05.2017'!R[-13]C[3])"
        
        Range("E40").Activate
        With ActiveCell
            .FormulaR1C1 = "=SUM('14.06.2017:30.05.2017'!R[10]C[3])"
        End With
        Selection.AutoFill Destination:=Range("E40:E44"), Type:=xlFillDefault
                
    End With
    End Sub

    Nu had ik graag de naam van de werkbladen “dynamisch” gemaakt door middel van een inputbox met de vraag van het de naam van het eerste werkblad en het laatste werkblad.
    Ik heb dit reeds op verschillende manieren geprobeerd maar ik krijg dit niet aan de praat.
    Weet jij misschien een elegantere oplossing

    • De basiscode (zonder foutafhandeling e.d.) voor de oplossing met een inputbox kan er als volgt uitzien:

      Sub Betterwin()
          Dim sht1 As String, sht2 As String
          sht1 = InputBox("Naam eerste sheet", "sheet 1")
          sht2 = InputBox("Naam tweede sheet", "sheet 2")
          ActiveCell.Formula = "=sum('" & sht1 & ":" & sht2 & "'!B2)"
      End Sub

      Maar ik vind deze oplossing zelf niet heel erg fraai. Ik zou zelf hiervoor een formulier gebruiken met 2 comboboxen. Alle aanwezige sheetnamen worden dan in de comboboxen getoond, zodat de gebruiker niks hoeft te typen en er altijd sheetnamen worden gekozen die daadwerkelijk bestaan.

      Daarnaast is jouw code is nog wel voor verdere verbetering vatbaar. Bijvoorbeeld Activate is maar zelden nodig. Dan wordt het iets als: Range(“E6″).Formula=”….”

      Groeten, Manfred

  • Beste Manfred,
    Is dit eveneens mogelijk met tekstvelden? Ik geef concreet een voorbeeld om het makkelijker uit te leggen.

    Mijn excel bestand heeft een 60tal werkbladen waarbij op elk tabblad extra info over een persoon staat. In (bijv) cel B1 staat de naam van elke persoon. Nu zou ik graag een lijst met alle namen uit de verschillende tabbladen bekomen zonder dit zelf manueel in te voeren. Is dit mogelijk?

    Grt

    • Beste Sofie,
      Dat kan zeker. Je kunt natuurlijk op het overzichtsblad onder elkaar een celverwijzing maken naar cel B1 van elk werkblad, maar dat is natuurlijk redelijk bewerkelijk. Het zou misschien ook met één formule kunnen die naar onderen gekopieerd kan worden, maar dat is geheel afhankelijk van de opbouw van je bestand en dan met name van de naamgeving van je tabbladen. Maar ik denk dat het handiger is om hiervoor een macro te maken.
      Groeten, Manfred

  • =SOM(‘jan:dec’!C3) ik wil graag verticaal zoeken op deze formule aanvullen ipv. de vaste C3.
    =VERT.ZOEKEN($Q5;JAN!$I$3:$K$42;2;ONWAAR) is de aanvulling.

    vraag: hoe moet dit?
    Ik stel het zeer op prijs als u het antwoordt hierop kunt geven. Ik zit al enige tijd mee te worstelen.

    m.vr.gr. Teus de Swart

    • Bedankt voor uw reactie, maar ik begrijp niet exact wat u bedoelt. De C3 in de formule wilt u flexibel maken en vervangen door de aangegeven formule met VERT.ZOEKEN?
      Daar is wellicht iets voor te verzinnen, maar dan moet ik eerst weten hoe de uitkomst van de VERT.ZOEKEN-formule eruit ziet, zodat ik weet hoe deze getransformeerd kan worden naar een cel-adres. Of bedoelt u wat anders?

  • Dag Manfred ,

    ik beheer bij ons een aantal magazijnen waarin zich veel verschillende loten bevinden .
    Ik heb van deze magazijnen een grondplan in exell gemaakt –> = effectieve fysieke stock .

    Nu wil ik de stocklijst ( systeemlijst ) eveneens in dit grondplan steken als extra tabblad
    om vervolgens een vergelijking te maken tussen de lotnummers op die betreffende lijst
    en de lotnummers die voorkomen op het grondplan .
    Let wel : elke magazijn heeft zijn eigen tabblad vb.: AST 1 ; AST 2 ; AST 3 .

    Alvast bedankt voor uw support
    Chris

    • Dag Chris,
      Daar is waarschijnlijk wel iets voor te verzinnen, maar op basis van de gegeven info is daar verder weinig zinnigs van te zeggen. Het handigste is om een een voorbeeldbestandje te sturen. Zie hiervoor mijn contactgegevens. Ik wil er dan wel even vrijblijvend naar kijken.
      Manfred

  • Dag Manfred,
    Bedankt voor al deze bruikbare informatie! Echter, er bleef nog één ding over wat me nog niet helemaal duidelijk was: stel dat je op Blad1 in C2 een gegeven hebt en op Blad2 in C4 een gegeven. Hoe zou het laatste deel van een formule er uit moeten zien om het voor elkaar te krijgen deze twee gegevens bij elkaar op te tellen in Blad3 (wat komt er in plaats van C3 in de formule te staan?).

    Heel erg bedankt alvast voor uw reactie! Met vriendelijke groet.

    • Als het om twee cellen gaat kun je gewoon =Blad1!C2+Blad2!C4 gebruiken. Of bedoel je wat anders?

  • Beste Manfred,

    ik vroeg me af: als ik gebruik maak van formules over verschillende werkbladen heen (bijvoorbeeld een gemiddelde waarde) en ik wil graag nog een extra werkblad (of meerdere) toevoegen, hoe kan ik dat doen op zo een manier dat de berekening van de gemiddelden behouden blijft? Met andere woorden: dat ik niet opnieuw de formules moet invoeren, maar dat Excel de nieuwe werkbladen automatisch meepakt in de berekening. Is dat mogelijk?

    Bedankt alvast voor je reactie!

    Vriendelijke groeten,
    Fred Jonker

    • Beste Fred,
      Als je ervoor zorgt dat het nieuwe blad gepositioneerd wordt tussen het eerste werkblad van de formule (in mijn voorbeeld werkblad ‘jan’) en het laatste werkblad van de formule (in mijn voorbeeld werkblad ‘dec’), dan wordt dit nieuwe werkblad automatisch meegenomen en hoef je de formule over meerdere werkbladen niet aan te passen.

      Vriendelijk groet,
      Manfred

  • Als ik de totalen van de werkbladen week 1 t/m week 52 volgens de hierboven aangegeven som wil optellen, maakt Excel er =SOM(‘week1:[week52]week52’!F6) van en krijg ik in de cel #VERW! Wat doe ik fout?

    • Ik kan van afstand niet zien wat er fout gegaan is. Om het goed te krijgen zou je normaal gesproken het volgende kunnen doen: selecteer de cel met de betreffende formule en druk op F2 en haal in de formulebalk het gedeelte ‘[week52]’ weg en druk op enter. De optelling zou dan moeten werken.

  • Beste Manfred,

    Ik heb 2 sheets 1 met adressen met verjaardagen en chassisnummers en een anders waar ik een overzicht moet maken van oudste en jongste chassis nummers hoe kan ik de ene linken aan de andere ??
    alvast bedankt voor uw antwoord

    • Hallo Jos,
      Ik begrijp niet helemaal wat je bedoelt. Je hebt het over adressen en verjaardagen. Deze verjaardagen hebben neem ik aan betrekking op personen. Maar op je wilt op de andere sheet een overzicht van het oudste en jongste chassisnummer. Uit je omschrijving kan ik niet opmaken hoe ik die kan bepalen. Hoe dan ook, zonder een representatief voorbeeldbestand is het moeilijk om hier in algemene zin iets over te zeggen. Voor jouw vraagstelling is vast en zeker een oplossing te verzinnen (met formules of met VBA), maar hoe die oplossing er uit ziet is geheel afhankelijk van de opbouw van je bestand en de gewenste output.

  • Beste Manfred,

    ik wil doormidel van een macro een leeg kopie maken van tablad met daarin alle formulens er in, maar nog geen meetgegevens.
    de kopien van dit werk blad staat een formule die over meerdere werkbladen de gemiddelen bereken.
    echter wil ik dat deze formule wel als mee neemt voor dit kopie werkblad maar niet alle waarden in de kopie werkbladen erachter pakt.

    alvast bedankt voor uw antwoord

    • Hallo Joost,

      Het is prima mogelijk om hiervoor een macro te maken, maar zonder (voorbeeld)bestand valt hier verder weinig over te zeggen. Ik weet namelijk niet hoe je bestand er precies uitziet en om welke formules het gaat, dus ik kan daarom niet aangegeven hoe de macro eruit moet gaan zien.

  • Beste Manfred,

    Ik zit met een probleempje,
    Ik ben voor mijn werk bezig een overzicht te maken met de in behandeling genomen ideeën en indien er een cadeau wordt toegekend is het de bedoeling dat op het volgende werkblad de voorraad wordt vermindert. Zou jij mij hiermee kunnen helpen?
    Ook zou ik willen weten of het mogelijk is, om vanuit een rij welke wordt ingevoerd op een ander blad om deze op de juiste manier automatisch te kunnen plakken in het hoofdoverzicht.

    ik kom er even zelf niet meer uit. 🙁

    Alvast bedankt.

    • Hallo Doreen,
      Dank voor je reactie.
      Wat jij wilt bewerkstelligen is normaal gesproken wel mogelijk met Excel.
      Zou je me daarom een representatief (voorbeeld)bestand kunnen mailen? Ik kan dan bekijken hoe dit het beste aangepakt kan worden.
      Alvast bedankt.

  • Hallo Manfred,

    Ik heb met belangstelling over de Exel formules op meerdere tabbladen zitten lezen.
    Ikzelf zit met het volgende:
    Ik wil over de 12 maanden een berekening laten toevoegen van het vorige tabblad + een getal.

    Bijvoorbeeld: =Januari!J10 (vorig werkblad)+75
    Het zal mogelijk simpel zijn, maar het lukt me niet!

    Met vriendelijke groet,

    Jan

    • Hallo Jan,
      Je kunt natuurlijk gewoon in de betreffende cel een = teken intypen en dan met dan de cel van het vorige tabblad aanwijzen. Maar is het de bedoeling dat het een algemene formule wordt die op elk tabblad automatisch verwijst naar het vorige tabblad? Dat laatste geval is minder eenvoudig in Excel, maar er zijn natuurlijk wel oplossingen voor te verzinnen. Ik zie dat jouw tabbladen de maanden van een jaar als naam hebben. In dit geval zou je de volgende formule eens kunnen testen:

      =INDIRECT(TEKST("1-"&BLAD()-1&"-2019";"mmmm")&"!J12")+75

      Dit werkt vanaf Excel versie 2013. Ik ga er hierbij vanuit dat de eerste sheet Januari heet. Als dat niet het geval is zul je dat moeten corrigeren door van de functie BLAD() het betreffende aantal sheets voor blad Januari af te trekken.

      • Bedankt Manfred.

        Ik ben er uit, het werkt.
        Bedankt voor je hulp.

        Groetjes, Jan

  • Goedemiddag,
    Ik wil graag optellen hoevaak een naam voorkomt in een andere TAB.
    Ik gebruik daarvoor de formule =AANTALLEN.ALS (A1:A500;”JULIA”)
    Deze werkt normaliter wel, maar gezien de informatie die opgeteld moet wroden in een andere TAB staat doet hij het niet, hoe kan ik dit toevoegen aan de formule?
    De andere tab waar het om gaat heet LOPENDE AANVRAGEN

    Bedankt!!

    • Hoi Julia,

      Dan moet je de tabbladnaam toevoegen aan de formule. Het wordt dan:

      =AANTAL.ALS('LOPENDE AANVRAGEN'!A:A;"JULIA")
  • hoe kan ik een formule met tabbladen doortrekken zodat het tabblad altijd verspringt de cel nummer hab ik vast gezet VB.
    =Sheet48!$F$26 ik wil deze formule in de volgende cel met sheet 49 maar weet niet hoe ik die simpel kan doortrekken dat de tabbladen veranderen.

    • Hoi Gitte,
      Dat kan met behulp van de functie INDIRECT. Als je voor de formule van sheet48 de volgende formule gebruikt dan kun je deze doortrekken naar beneden waarbij de tabbladnaam verandert:

      =INDIRECT("sheet"&RIJ(A48)&"!F26")
  • hallo,
    enkel het eerste en het laatste werkblad worden opgeteld. Hoe kan ik dit oplossen? ik gebruik =som(‘a:z’!F11)

    • Bij jouw formule worden de waarden van F11 van tabblad A tot en met Z opgeteld. Dus ook alle tussenliggende tabbladen tussen A en Z worden meegeteld. Ik zou het bestand moeten zien om te bekijken wat de oorzaak is dat bij jou ogenschijnlijk de tussenliggende tabbladen niet worden meegeteld.

  • Is het mogelijk als in een bepaald tabblad een cel een bepaalde kleur heeft, dat die dan automatisch geplakt wordt in een ander tabblad?

Geef een reactie

Het e-mailadres wordt niet gepubliceerd.